Acer 4530 and Ubuntu 9.04 – Perfect!

It’s here ladies and gentlemen … the perfect match. Ubuntu 9.04 appears to be well and truly tailor made for Acer 4530. Absolutely everything works. I’ve got the wifi working, sound playing, nvidia graphics working seamlessly with compiz-fusion.

The best part is, it’s working off a windows NTFS partition with write access to all the NTFS partitions, thanks to Wubi! And the entire installation took a little over 5 minutes. That’s even less than what it would have taken if I had installed a full blown Ubuntu installation.

My biggest concern was about the Atheros wifi card which has always been a problem in Linux because of the bad drivers. But Ubuntu 9.04 works out of the box. My laptop uses the ath9k kernel driver which is working great.

I feel everyone should give this a shot, windows users included. I’ve been dying to get rid of the vista home premium that came bundled with my laptop and along comes ubuntu 9.04 with it’s amazing compatibility. I’ve been a die-hard gentoo user for the past 5 years and now seeing how convenient ubuntu is, I finally feel Linux has arrived!

Edit:

Ok, here’re some more details:

This is my laptop: Acer 4530-6823 which has AMD Athlon XP 64bit QL-62 processor. I’m using the 32bit version of Jaunty and the default Gnome desktop.

Of course, I would say that this distro, although miles ahead of the others, isn’t without some bugs. The audio port for headphones/speakers doesn’t work out of the box. Neither does the built in mic. But I think this can be fixed by updating/configuring alsa.

But the webcam works fine. I’ve tried it with Ekiga and it’s working.

I did try installing Ubuntu 8.10 on my friend’s Acer 4530 which was identical except for the memory and HDD and I gave up after spending a miserable few hours struggling with it. Same was the case with Suse. But the ease with which I could get Ubuntu 9.04 up and running is amazing. If you’ve got this laptop, I would highly recommend this version. Also, if your laptop has got an atheros wifi card. This is the first Linux distro I’ve seen which has got it working out of the box (I couldn’t get it to work in any of the others even after struggling with them – Ubuntu 8.10, OpenSuse 11.1, Gentoo!).

Edit2:

Ok, got the headphones working. Followed the instructions in the post given by Asif over here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/360181/comments/1